PVS target devices freeze and fail to reconnect

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Article ID: CTX696040

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Updated On:

Description

PVS target devices freeze during a PVS reconnect, fail to reconnect successfully to PVS servers, and the PVS target devices will not recover once this occurs.

Memory dumps show that PVS target device software is in reconnect mode, attempting to reconnect to the PVS server.

Further investigation found the behavior only occurs when target devices’ disks have Palo Alto terminal services agent installed.

Environment

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Cause

PVS reconnects may be interrupted by Palo Alto Terminal Server Agent.

Palo Alto Terminal Server Agent requires specific configuration if it is installed on a PVS vdisk.

Resolution

Boot the vdisk in private mode and configure registry options for Palo Alto Terminal Server Agent when running on a PVS streamed machine.

Registry configuration:

    • [HKEY_LOCAL_MACHINE\SOFTWARE\Palo Alto Networks\TS Agent\Adv]
      "EnableDetachFilter"=dword:00000001

Notes:
This setting is recommended to be enabled in Citrix PVS Environment.
When this is enabled, Terminal Server Agent activates PVS-specific feature-set to avoid issues such as Non-Responsive Windows Server following PVS Shut-Down or Failover

Issue/Introduction

PVS target devices running Palo Alto Palo Alto Terminal Server Agent freeze and fail to reconnect to PVS servers.

Additional Information

Palo Alto Documentation for Terminal Server Agent Advanced Configuration using Windows Registry

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000HCccCAG