PVS server and Citrix DaaS Remote PowerShell SDK updates

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Article ID: CTX695861

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Updated On:

Description

PVS server installation media includes a specific version of Citrix DaaS Remote PowerShell SDK.

The version shipped with the installation media is the only version of the SDK which is supported with that version of PVS.

Installing different versions of the DaaS Remote PowerShell SDK that is shipped with PVS is not supported and may prevent expected PVS console operation.

Environment

"Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it."

Cause

Installing different versions of the DaaS Remote PowerShell SDK that is shipped with PVS is not supported and may prevent expected PVS console operation.

Resolution

If a newer version of the SDK has been installed on the PVS server.

  1. Close all PVS consoles.
  2. Uninstall the newer version of the SDK.
  3. Mount the original PVS install media.
  4. Navigate to the installation path for the SDK in a subfolder of “<ISO>:\ Server\ISSetupPrerequisites\” containing the file "CitrixPoshSdk.exe"
  5. Run the installer "CitrixPoshSdk.exe"

If an admin is prompted to install newer versions of the SDK, they can be suppressed:

  1. Open the registry and navigate to path HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\PoshSdk
  2. Edit the REG_SZ call “Version” and change the Value Data to “8.0.0.0”
  3. This will suppress future popups.
  4. If you reinstall or upgrade PVS software on the PVS server, ensure this registry key is configured as above.

Issue/Introduction

PVS server supports only the Citrix DaaS Remote PowerShell SDK which is included in the original installation media.