MCS provisioned catalog on GCP fails with Exception "GetConfigurationDataForItem: Value cannot be null" during Catalog Rollback/Update/Creation

book

Article ID: CTX695820

calendar_today

Updated On:

Description

This was the behaviour as the "In Use By" paramater of the disk associated with the old snapshot was showing as 'NONE" instead of a value. This can be checked by viewing the Disk Properties.

This value ideally should have the name of the VM instance attached to the disk. There will be a value present for the present master image.

Cause

This was the behaviour as the "In Use By" paramater of the disk associated with the old snapshot was showing as 'NONE" instead of a value. There will be a value present for the present master image to proceed with the catalog creation or update.

Resolution

Attach the VM instance to the disk associated with the snapshot where creation/update/rollback is required. The VM attached will be used for the provisioned machine specifications, hence choose accordingly. Once done, the value of the "In Use By" parameter should change to the name of the VM instance (as shown in the below screenshot) and the rollback/update will be completed as expected.

image.png

Issue/Introduction

When trying to create/update/rollback the catalog with the master image for a MCS provisioned catalog on GCP, it fails with the error below:

Action Name: MC_RollbackMachineCatalogInitialization
Exception:
    StudioErrorId : ProvisioningTaskError
    ErrorCategory : NotSpecified
    TaskState : UnknownError
    TaskStateInformation : Terminated
    ErrorId : ManagedMachineGeneralException
    Operation : ValidatingInputs
    ErrorMessage : Exception in GetConfigurationDataForItem: Value cannot be null.
Parameter name: instanceName
    Error Source : CitrixOrchestration