CWA Windows - After uninstalling CWA Windows 2405 and installing CWA 2409 Zoom optimisation breaks

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Article ID: CTX695564

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Updated On:

Description

Issue relates to the method used to uninstall the client .

Cause

On further investigation TrolleyExpress is used to uninstall the CWA Windows via a script.

${env:ProgramFiles(x86)\Citrix\Citrix Workspace 2405\TrolleyExpress.exe /uninstall /silent

The MSI logs created are from TrolleyExpress .

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Uninstall logs should show CWAInstaller .

 

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Resolution

Starting with Citrix Workspace app for Windows 2311.1 TrolleyExpress is replaced with CWAInstaller .

See https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/install

TrolleyExpress should not be used for the uninstallation via command line .

To find the recommended command line for uninstallation please check the registry.

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\CitrixOnlinePluginPackWeb\UninstallString

If the correct uninstallation method is used the problem is not seen.

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Issue/Introduction

As part of the upgrade process  the older version of CWA is uninstalled and new version is installed. However this breaks Zoom optimization and Cisco Webex optimisation..

This does not happen if there is an in-place  upgrade.

The uninstall process removes the  registry keys of 3rd party plugins such as

 

Zoom:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\ZoomCitrixMediaPlugin

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICAClient\Engine\Configuration\Advanced\Modules\ZoomPluginAutoUpdateService

Cisco (Webex):

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\VDCISCO

 

After installation of the higher version of CWA, these registry keys  are not added back and Zoom HDX optimization breaks due to the missing registry entries .

Additionally, launching desktops can fail with error ."Unable to Start, You might be having an issue with a Citrix virtual driver (****). Contact your system administrator for further assistance "

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As a workaround  the Zoom and Cisco Plugins can be reinstalled or else the missing registry entries created manually .