CWA for Mac - When launching session from web browser, a dialog "There is no application set to open the URL" is prompted

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Article ID: CTX695506

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Updated On:

Description

In a MacOS device with CWA for Mac installed, when launching session, a dialog with message "There is no application set to open the URL receiver://.../Citrix/.../clientAssistant/getIcaFile/..." is always prompted. The dialog asks end user to "Search the App Store for an application that can open this document, or choose an existing application on your computer".

Cause

'WorkspaceHelper' component inside CWA for Mac fails to be invoked upon the session launch from web browser. It is triggered by a recent Storefront server certificate renew.

Resolution

The issue has been addressed by cleaning up the web browser Internet cache and restarting the web browser.

Issue/Introduction

The article describes an ICA session launch failure in a Mac device related with Storefront server certificate.