Citrix Virtual Apps and Desktops - Intermittent Black background behind pop-up windows in a Published Application

book

Article ID: CTX695496

calendar_today

Updated On:

Description

In some cases, customers are seeing a black background appear when a pop-up window is present in a published application. The black background shows up behind the main application window, but does not span the entire screen.

Applications are published from a multi-session VDA running CVAD 2507 on Windows Server 2025.

This issue was not seen in earlier versions of the VDA or Windows Server.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

The black window is related to snap layouts (as seen in Windows 11 when you drag a window to the top of the screen). This is a transparent window owned by the ShellAppRuntime process. Currently, transparent windows are not supported in published applications. a

Resolution

In the long term, this will be addressed when transparent window support is added in a future CVAD release, but in the short term, the current recommendation is disable the snap bar with the following registry setting on the VDA

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
EnableSnapBar DWORD 0x0

Issue/Introduction

In some cases, customers are seeing a black background appear when a pop-up window is present in a published application. The black background shows up behind the main application window, but does not span the entire screen.