Citrix Workspace App for Windows - installation failed with error code: 40034

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Article ID: CTX695461

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Updated On:

Description

CWAInstaller* log shows: Exit code is 40034

 

CWAInstallerHelper::CWA_InstallerHelper::WriteLogs(29) - ExitInstance : Exiting Application with error Code : 40034

 

The component installation failed:

CInstallationManager::InstallComponent(1088) - Component Install Status: ID = ReceiverInside, InstallMode = Install, InstallResult = 1603, InstallSuccess = False, InstallRebootRequired = False, InstallSuppressed = False

 

Error code 40034 ( https://support.citrix.com/external/article/CTX695019/citrix-workspace-app-installer-uninstal.html )

40034

Installation error: A Microsoft Installer installation failed. Try again, and if the issue persists, contact your system administrator.

 

The issue was with the Recever Inside installation.

RIInstaller* log shows error status 1603 (this is generic error code):

 

Windows Installer installed the product. Product Name: Citrix Workspace Inside. Product Version: 24.2.3001.7. Product Language: 1033. Manufacturer: Citrix Systems, Inc.. Installation success or error status: 1603.

 

If we check what happened during installation:

Note: 1: 2203 2: C:\Windows\Installer\inprogressinstallinfo.ipi 3: -2147287008 

DEBUG: Error 2203:  Database: C:\Windows\Installer\inprogressinstallinfo.ipi. Cannot open database file. System error -2147287008

Product: Citrix Workspace Inside -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203. The arguments are: C:\Windows\Installer\inprogressinstallinfo.ipi, -2147287008, 

 

This indicates an issue with accessing a system file: inprogressinstallinfo.ipi

Process Monitor trace captured during installation is very useful in scenarios like this.

Filter:

The trace shows that 4 processes accessed the file during installation:

  • CWAInstaller.exe
  • msiexec.exe
  • AV software
  • Security software

Additional filter in process monitor trace can help you identify what process locks the file and releases the lock (or does not release).

*Logs can be found in C:\Program Files (x86)\Citrix\Logs\CTXWorkspaceInstallLogs* folder

Environment

Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.

 

Cause

Security software locked the file during installation.

Resolution

Workaround: You can configure 3rd party security software / AV and add exclusions. You can exclude inprogressinstallinfo.ipi from scanning / monitoring during Citrix Workspace App installation.

Please contact 3rd party vendor for assistance. 

Issue/Introduction

Citrix Workspace App for Windows might fail during a new installation or upgrade. 

This issue can occur with different versions of the product.

Additional Information

Process Monitor tool: https://learn.microsoft.com/en-us/sysinternals/downloads/procmon

Error codes: https://support.citrix.com/external/article/CTX695019/citrix-workspace-app-installer-uninstal.html