CVAD - Search box of Windows 11 multi-session OS may not respond intermittently in ICA session

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Article ID: CTX695419

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Updated On:

Description

When end user is using ICA desktop session hosted by Windows 11 multi-session OS, intermittently, left-click on search box in Windows taskbar or Windows start menu may not get a response. Once the issue occurs, a restart of Windows Explorer from Windows task manager can make a recovery.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

Windows 11 search box is managed by Microsoft SearchHost.exe. The unresponsive search box pinpoints a hung state of SearchHost.exe,

Resolution

The issue has been addressed after excluding Citrix hooks from Windows process SearchHost.exe per the following Citrix registry change.

  1. Open the Registry Editor.
  2. Open the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CtxUvi
  3. Right-click on "UviProcessExcludes" and click "Modify".
  4. Append "SearchHost.exe;" to the end of the registry value string
  5. Reboot the affected VDA

Issue/Introduction

The article describes a Windows search box not responding issue related with Citrix hooks.