Citrix Cloud - Cloud Connector Connectivity Check Utility throws error message "Requested registry access is not allowed."

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Article ID: CTX695365

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Updated On:

Description

When running Cloud Connector Connectivity Check Utility in a Cloud Connector, the utility shows "Testing Service Connectivity" failure with a detailed error message,
"Connectivity check error, message A service needed to perform the test may not be running properly. Please reboot the machine and try again. details System.Security.SecurityException: Requested registry access is not allowed."

Cause

The user account that is used to run Cloud Connector Connectivity Check Utility actually has insufficient permission in registry access.

Resolution

To address the error, please run Cloud Connector Connectivity Check Utility with administrative privilege, e.g., right-click the utility and select "Run as administrator".

Issue/Introduction

The article describes a Cloud Connector Connectivity Check Utility runtime error due to insufficient permission