LAS - Failed to generating registration code

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Article ID: CTX695264

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Updated On:

Description

Customer License Server cannot access the Internet directly, the proxy is configure on the Operation System.

When trying to register the Citrix License Server to Citrix Cloud, after clicking registration button and waiting for a while, it pops out a warning dialog "Failed to generate registration code".

Error details: There was an error in generating registration code. Try again.

 

Cause

When generating the registration code, License Server needs to communication with the API URL "trust.citrixnetworkapi.net".

But License Server will not use the proxy configured on the Operation System, it needs to be configured separately.

The network traces show that the License Server will use System configured DNS Server to resolve the hostname "trust.citrixnetworkapi.net" and communication to "trust.citrixnetworkapi.net" with Local IP address, instead of forwarding the package to proxy.

Resolution

Starting with License Server version 11.17.2.0 build 43000, you can view and configure proxy server settings from the Citrix Licensing Manager UI. You can edit the settings to add, modify, or remove a proxy server as needed.

Do the following to configure a proxy server:

  1. In the Citrix Licensing Manager, click the Settings in the upper right of the UI.
  2. Click Server Configuration.
  3. Navigate to Configure a Proxy Server section.

  4. Click the Edit  to configure a new proxy server or to update an existing proxy server.

  5. Enter the proxy server name and proxy port number in the following format:

    proxy server name:port number

    For example: 10.211.55.5:808. (This port can be IPAddress:Port or Hostname:Port.)

  6. Click Save. The proxy server configuration is saved successfully.

Issue/Introduction

When trying to register the Citrix License Server to Citrix Cloud, it reports the error: "Failed to generate registration code"