Citrix Workspace Environment Management agent 2503, 2507 fails to connect to WEM Service.

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Article ID: CTX695216

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Updated On:

Description

Citrix Workspace Environment Management agent 2507 fails to connect to WEM Service.

Agent shows an error message “An error occurred while building your environment."

Citrix WEM Agent Host Service Event log shows the error  "Service cannot connect to the service controller."

WEM Agent log shows the message "Offline Mode not allowed while Offline State Detected --> Exiting"

Cause

When installing the VDA Agent 2503 and 2507 LTSR, Citrix Workspace Environment Management agent will be installed with deployment type "Basic Deployment.

Citrix Workspace Environment Management agent is now integrated with the VDA and is always installed. This cannot be deselected when installing using the GUI.

Note : Issue is observed on fresh VDA install only.
Upgrading the WEM Agent to version 2507 via the VDA 2507 LTSR installer will automatically upgrade existing WEM Agents (Cloud or on-premises) without changing their deployment mode.

Resolution

Refer to Switching the agent deployment type for changing the deployment mode to OnPrem or Cloud.

Issue/Introduction

Citrix Workspace Environment Management agent 2503, 2507 fails to connect to WEM Service.