DaaS: Unable to delete a delivery group, Error "Database could not be contacted"

book

Article ID: CTX695134

calendar_today

Updated On:

Description

You may be unable to delete a delivery group from Web studio and PowerShell SDK, failing with the error "Database could not be contacted"

Environment

None.

Cause

It is caused by the MachineConfiguration linked to the Delivery Group. If you run following PowerShell cmd let, you may see the Uid value left in the MachineConfigurationUids as shown below:

 

Get-BrokerDesktopgroup -Name "<Name of the Delivery Group>"

MachineConfigurationNames                         : {<Machine Configuartion name>}
MachineConfigurationUids                             : {XX}

Resolution

Please use following steps to remove or delete the Delivery Group:

  1. Download the Remote PowerShell SDK
  2. Install the SDK on any computer in your resource location except the Cloud Connector.
  3. Add the Citrix snap-ins: asnp citrix*.
  4. Execute the cmdlet, Get-XdAuthentication, it prompts you for Citrix Cloud authentication.
  5. Run following PowerShell cmd let:

Get-BrokerMachineConfiguration -Uid <Value> | Remove-BrokerMachineConfiguration -DesktopGroup "<Name of the Delivery Group>"

Issue/Introduction

You may be unable to delete a delivery group, failing with the error "Database could not be contacted"