Virtual Application - The published application icon doesn't dock to Windows taskbar of the client machine

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Article ID: CTX695121

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Updated On:

Description

When launching a published application, the application window is properly created and displayed in the client machine. However, after minimizing the application window, the application icon doesn't dock to Windows taskbar of the client machine. As a result, end users cannot restore the published application window.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

In the affected VDA, "SeamlessFlags" registry value under [HKLM\CurrentControlSet\Control\Citrix\wfshell\TWI] has been configured with a combined value, which contains value 0x80, indicating "iconic windows will not be sent to the ICA client". That results in the published application icon not appearing in client-side Windows taskbar once the published application window is minimized.

Resolution

To address the issue,

  • Please verify if "SeamlessFlags" registry value under [HKLM\CurrentControlSet\Control\Citrix\wfshell\TWI] has been configured with a combined value containing 0x80
  • Subtract 0x80 from the combined value and then save the change
  • Launch a new application session for verification

Issue/Introduction

The article describes an invisible published application icon issue caused by a misconfiguration in "SeamlessFlags" registry value.