Storefront - "Change password" option is missed from "Account Settings" menu when non-Admin users sign-in storefront

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Article ID: CTX695081

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Updated On:

Description

When non-Admin users sign-in Storefront and expand "Account Settings" menu in the upper right corner, it is observed that "Change password" option is missing.

Cause

The visibility of storefront "Change password" option depends on "Network access: Restrict clients allowed to make remote calls to SAM" policy setting in AD domain controllers.
In "Default Domain Controllers Policy" policy of the affected environment, "Network access: Restrict clients allowed to make remote calls to SAM" setting has been set restricted to O:BAG:BAD:(A;;RC;;;BA), standing for "Domain Admins" group. that's why "Change password" option is invisible to non-admin users.

Resolution

To make the "Change password" option visible to non-admin users as well, "Authenticated Users" group should be added to the policy setting "Network access: Restrict clients allowed to make remote calls to SAM"

  • Note: After adding "Authenticated Users" group, the policy setting should appear like O:BAG:BAD:(A;;RC;;;BA)(A;;RC;;;AU).

Issue/Introduction

The article describes a storefront "Change password" option invisibility issue caused by the improper "Network access: Restrict clients allowed to make remote calls to SAM" AD policy setting.