Session Recording - ICA session is not recorded by session recording agent

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Article ID: CTX695040

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Updated On:

Description

When an ICA session is launched, session recording agent doesn't start to record the session activities. In the Windows Application event, session recording agent event 3014 is logged with error message "The Session Recording feature requires a Platinum license to function. Session Recording will be disabled".

Cause

The on-prem CVAD environment is using Citrix Universal Advanced Plus license, which doesn't support Session Recording feature.

Resolution

In the on-prem CVAD environment, please upgrade the existing "Advanced Plus" license to "Premium" license to enable the session recording feature.
Or, stay with the existing "Advanced Plus" license and migrate the on-prem CVAD environment to Citrix DaaS.
Note: Session Recording currently supports Citrix DaaS Advanced, Advanced Plus, Premium, and Premium Plus editions.

Issue/Introduction

The article describes a session recording failure caused by unsupported license type.

Additional Information

https://docs.citrix.com/en-us/session-recording/current-release/system-requirements.html#session-recording-agent