App Layering - Missing optical drive results in "UUID_INVALID" when publishing an image or creating a layer on XenServer

book

Article ID: CTX694929

calendar_today

Updated On:

Description

  • This only applies to XenServer connectors.
  • The connector type (MCS, PVS, Standard) does not matter.
  • In 'maservice.log' you will see the error with no SR called out. If an SR UUID is shown, then you may need to look at other possible causes as this solution may not apply.
XenMcsConnector: Caught exception trying to deploy compositing machine: Uni.Core.Handlers.Exceptions.GlobalizedErrorException`1[Uni.Core.Contract.Results.XenErrorCategory]: MessageId=XenTaskFailed, DefaultTitle=, CategoryData={[XenErrorCategory { Message = "UUID_INVALID sr", Name = "Async.VM.provision", Description = "" }]}
  • The XenServer logs will show similar messages "Async.VM.provision" and "UUID_INVALID sr" also missing the SR number.

Cause

The root cause was found to be that the optical drive was not configured for the existing VM Templates. Selecting the template from within XenCenter you should see a Storage tab as part of the template's properties. If this tab is missing then there are no drives of any type configured on this template.

Missing Storage Tab

image.png

 

Storage Tab Present

image.png

Resolution

  1. Create a new VM template and be sure it has the optical drive assigned.
  2. No disks should be attached but an optical drive is needed for the App layering Compositing Engine.
  3. Then update the App Layering XenServer connector to point to the new template.

Issue/Introduction

App Layering task fails with:

"Xen Task Failed 'UUID_INVALID

sr '

Name.Async.VM.provision, Description"