The customer can't add a XenServer 8.4 to their XenCenter, getting the error " failed to connect to <server IP> Could not create SSL/TLS secure channel"
The root cause was that the VM running XenCenter was missing the ciphers:
TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
XenServer 8.4 needs that these ciphers be available on the VM running XenCenter
Enable the missing ciphers
Enabled these 2 cipher suites by the following commands:
Enable-TlsCipherSuite -Name "TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256"
Enable-TlsCipherSuite -Name "TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384"
After upgrade to XS 8.4, Server can't connect to XenCenter, getting the error: "failed to connect to <server IP> Could not create SSL/TLS secure channel