Desktop session has no color. Session is displayed only in Greyscale.

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Article ID: CTX666255

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Updated On:

Description

There is no color when the users reconnect to existing session.

the Taskbar, Start menu and all the applications with in the desktop session are in grey scale.

Resetting the profile fixes the issue. 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

Windows Color Filtering was enabled in the users profile.

The registry key HKCU\Software\Microsoft\ColorFiltering was set to 1

Resolution

To disable Uncheck the "Use Color Filters" toggle, under: Settings -> Ease Of Access -> Color Filters 

If the issue is persistent, it is a good idea to use an application such as ProcMon (https://learn.microsoft.com/en-us/sysinternals/downloads/procmon) to run on the VDA console, then get a user who is repeatedly affected to log in, leave the session until you see the greyscale, then stop procmon, and look to see what application modified HKCU\Software\Microsoft\ColorFiltering. 

 

Issue/Introduction

After connection to a VDA, the whole session is in Black and White/Greyscale