Start menu not responding when using User Layer after image update
                    
                
                
                    
                        book
                        
Article ID: CTX477227
                        
                    
                    
                        calendar_today
                        
Updated On: 
                    
                 
                
                    
                
                    
                    
                        
                            
Description
                        
                        
                            Start menu does not respond in sessions using a User Layer after image update
                         
                     
                    
                    
                        
                            
                                
Environment
                            
                            
                                Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
                            
                         
                        
                    
                    
                        
                            
                                
Resolution
                            
                            
                                On the master image/ PVS vdisk in maintenance mode ensure Uniservice is set to stopped and disabled:

Ensure start menu service dependencies are present on the image and there are no duplicates:
This example is from windows 10 21H2 
HKLM\System\CurrentControlSet\Services\appReadiness\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\appvStrm\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\appvVemgr\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\camsvc\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\Dosvc\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\entAppSvc\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\stateRepository\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\storsvc\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\wpnService\DependOnService -> includes uniserviceHKLM\System\CurrentControlSet\Services\wsearch\DependOnService -> includes uniservice
Problem Cause
In this case an admin had logged onto the image in a maintenance version causing Uniservice startup type to change to manual - started
As a result on every user logon to this image services dependent on Uniservice were started prior to User layer mount - this resulted in an unresponsive start menu
Uniservice must be set to stopped and disabled prior to user logon.
During logon ulayersvc sets Uniservice to manual and startedOn reboot the disk is reset - which is why it is important to reboot between session to non-persistent VDI
                             
                         
                        
                    
                        
                            
                                
Issue/Introduction
                            
                            
                                Uniservice startup type incorrect on user logon causing dependent services to start prior to user layer mount
                            
                         
                        
                    
                    
                    
                
                    
                        
                            Was this article helpful?
                        
                        
                            
                                thumb_up
                                Yes
                            
                            
                                thumb_down
                                No