Citrix HDX Session might freeze intermittently after a few minutes when the client machine has non-existent or non-responsive printers.

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Article ID: CTX462384

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Updated On:

Description

Citrix HDX session may freeze a few minutes after the session launch.
Users can successfully reconnect to the session and continue to work till the session freezes again.

Affected Environments

This issue has been observed in, but may not be limited to, the following environments:

Client Endpoint: CWA versions older than CWA 2402 CU4 and 2503.10

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Cause

Non-existent or non responsive network printers on client devices

Resolution

  • This issue is fixed in CWA 2402 LTSR CU4 and CWA 2503.10 CR.

https://docs.citrix.com/en-us/citrix-workspace-app-for-windows/2402-ltsr/whats-new/cumulative-update-4/fixed-issues

HDX sessions might freeze intermittently after a few minutes when the client machine has non-existent or non-responsive printers. [CVADHELP-23427]

 

  • On CWA 2402 LTSR CU4 and CWA 2503.10, the following additional registry key must be created to apply this fix . This reg key is not required on CWA 2507 and above as it is enabled by default.

* On a 64-bit client OS: Create a REG_SZ "PMEnable" registry value equal to "TRUE" under `HKLM\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\ClientPrinterQueue`.

* On a 32-bit client OS: Create a REG_SZ "PMEnable" registry value equal to "TRUE" under `HKLM\SOFTWARE\Citrix\ICA Client\Engine\Configuration\AdvancedModules\ClientPrinterQueue`.

 

  • If the issue persists post implementing the fix, please reach out to Citrix support and provide CDF traces from both the client and the VDA.

 

Workaround

Remove non-existent or non responsive network printer from client devices.

 

Issue/Introduction

Citrix HDX Session might freeze intermittently after a few minutes when the client machine has non-existent or non-responsive printers.