
Webview is not starting because this policy evaluation is failing.
add authentication Policy Pol-Auth-SAML-NoAuth -rule "HTTP.REQ.URL.CONTAINS(\"/nf/auth/doAuthentication.do\")" -action NO_AUTHN
Customer has configured advanced Auth policies, but still going through classic flow (/vpn/index.html, /cgi/authenticate). This is why expression does not match /nf/auth/doAuthentication.do and hence Webview does not start.
On the NetScaler gateway run the following:
add authentication Policy Pol-Auth-SAML-NoAuth -rule true -action NO_AUTHN
OR
add authentication Policy Pol-Auth-SAML-NoAuth -rule "HTTP.REQ.URL.CONTAINS(\"/nf/auth/doAuthentication.do\")||HTTP.REQ.URL.CONTAINS(\"/cgi/authenticate\")" -action NO_AUTHN
Unable to add cloud store URL to Citrix Workspace app