Citrix Virtual Apps and Desktops - Windows File Explorer is Repeatedly Crashing on the VDA after Installing Updates or Applications

book

Article ID: CTX264843

calendar_today

Updated On:

Description

Customers may experience an issue where Windows File Explorer is repeatedly crashing on the VDA after installing Windows updates or new applications to their master image or vDisk, showing the following symptoms:

  • The master image or vDisk was recently updated.
  • After rolling out the image to production Windows File Explorer and possibly other processes are repeatedly crashing.
  • Creating below registry to exclude the process from loading Citrix hooks fixes the issue:

Key: HKLM\SYSTEM\CurrentControlSet\services\CtxUvi
Value Name: UviProcessExcludes
Type: REG_SZ
Value: Explorer.exe

Ref: https://support.citrix.com/article/CTX107825 

Cause

The Explorer.exe crash may be caused due to a Missing Entry  for either or both "C:\Program Files (x86)\Citrix\HDX\bin" and "C:\Program Files\Citrix\HDX\binin the “Path” variable under System Environment variables which is the variable used by the system account.

It may also be caused by a network path in the list above the Citrix path entry, which could cause a delay to querying the path. 

Both can lead to the delayed loading of the Citrix Hook – “ctxwsapi64.dll”, which causes the crash of the Explorer.

Resolution

To resolve this problem, the path variable needs to be checked under the system environment variable. Please follow the steps below to check the same:

  1. On the Start menu, right-click Computer.

  2. On the context menu, click Properties.

  3. In the System dialog box, click Advanced system settings.

  4. On the Advanced tab of the System Properties dialog box, click Environment Variables.

  5. Under the System Variables, select Path 

  6. click Edit... to open the Edit environment variable window (as seen below).
    • image.png
  7. Confirm there is an entry for both "C:\Program Files (x86)\Citrix\HDX\bin" and "C:\Program Files\Citrix\HDX\bin", if either are missing, please add them to the list using the button labelled New. (Please note for VDA 1912 and below, the entry will be "C:\Program Files (x86)\Citrix\System32\" )
  8. If the variables are present, confirm that these variables are above any network paths in the list eg \\ServerName\Path or any drive letter that is not the SystemRoot eg Z: by using the Move Up button  (this step may not be necessary if there are no network entries present).

 

 

 

Issue/Introduction

Customers may experience an issue where Windows File Explorer is repeatedly crashing on the VDA after installing Windows updates or new applications to their master image or vDisk