Failed to launch session "session_name". Error code: 2502 on Citrix Workspace App During App/Desktop Launch

book

Article ID: CTX255861

calendar_today

Updated On:

Description

The following error is returned by the Citrix Gateway to Citrix Workspace App when an application or desktop launch fails: Failed to launch session <session_name>. Error code: 2502

Cause

This error means that the Enlightened Data Transport (EDT) failed to establish a DTLS/UDP connection to the Citrix Gateway

Resolution

As the issue can be triggered by items ranging from the local network interfaces, ports, or down/up-stream appliances - it's best to consider this error a general connectivity impact through DTLS/UDP, and the communication layers should be investigated:

  1. Firewall ports on the local machines
  2. Proxy software on the local machines
  3. Office WAN/VLAN configurations
  4. Network stability

Issue/Introduction

Users receive message, "Failed to launch session <session_name>. Error code: 2502" on their respective Client Machines