Citrix Studio shows an error "Cannot find drive. A drive with the name 'CtxAppVServer_Computer' does not exist after upgrade to 1808 version.
book
Article ID: CTX238342
calendar_today
Updated On:
Description
Error:
"Cannot find drive. A drive with the name 'CtxAppVServer_Computer' does not exist."
More details:
Error Id: XDDS:B29E7FB5
Exception:
Citrix.Orchestration.Base.LogicModels.Exceptions.ObjectNotFoundException Cannot find drive. A drive with the name 'CtxAppVServer_Computer' does not exist.
Admin can see this error when using App-V Publishing node in Studio.
1) App-V server was added before the upgrade:

2) Admin tries to add a new APP-V server:

Resolution
Close Studio.
Copy the missing dll (Citrix.Diagnostics.Tracing.dll) to Studio location: C:\Program Files\Citrix\Desktop Studio from another folder located on 1808 DDC
Example:
C:\Program Files\Citrix\Trust\Service
C:\Program Files\Citrix\Orchestration\Service
You can also run Studio MSI installer again and repair the installation
Problem Cause
DLL not copied properly during upgrade.
Was this article helpful?
thumb_up
Yes
thumb_down
No