Unable to delete Machine Catalog- Error "IdentityPoolAlreadyLocked"

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Article ID: CTX225808

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Updated On:

Description

DesktopStudio_ErrorId : IdentityPoolAlreadyLocked
Sdk Error Message : Identity Pool is already locked.
Sdk Error ID : Citrix.XDPowerShell.AdIdentityStatus.IdentityPoolAlreadyLocked,Citrix.AdIdentity.Sdk.Commands.SetAcctIdentityPoolCommand
ErrorCategory : NotSpecified
 

Resolution

DesktopStudio_ErrorId : IdentityPoolAlreadyLocked
Sdk Error Message : Identity Pool is already locked.
Sdk Error ID : Citrix.XDPowerShell.AdIdentityStatus.IdentityPoolAlreadyLocked,Citrix.AdIdentity.Sdk.Commands.SetAcctIdentityPoolCommand
ErrorCategory : NotSpecified
 
  • Get-BrokerCatalog –Name [CatalogName]
  • Look at the "ProvisioningSchemeId" field.
  • Get-ProvScheme –ProvisioningSchemeUid [ID]
  • If the provisioning scheme and the host exist, then it is possible that the provisioning scheme does not have the correct entries, or if there are multiple provisioning schemes, they might reference different identity pools; which is a configuration that is not supported by Desktop Studio.
  • Check that the identity pool of the provisioning scheme exists.
  • Get-ProvScheme  -ProvisioningSchemeUid <UID> | fl -Property ProvisioningSchemeName, IdentityPoolName
  • Note the name of the identity pool
  • Get the identity pool: Get-AcctIdentityPool -IdentityPoolName <Name of the pool>
  • If the identity pool does not exist, then you must delete the provisioning scheme and recreate it. It is best, in this case, to use desktop studio to delete the Catalog and then to recreate it.
  • Get-AcctIdentityPool -Filter {Lock -eq $true} | Unlock-AcctIdentityPool
  • Unlocks all the locked identity pools.

Problem Cause

Locked identity pool