Citrix Virtual Apps and Desktops 2203 - Logon stuck in black screen for both RDP and ICA Sessions

Citrix Virtual Apps and Desktops 2203 - Logon stuck in black screen for both RDP and ICA Sessions

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Article ID: CTX694843

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Updated On:

Description

After upgrading Windows 2016 VDAs from 1912 LTSR CU9 to VDA 2203 LTSR CU 5 users started experiencing long logon times. The logon seems to get stuck in a black screen. Black screen is also observed when connecting over RDP to the machine. 

Environment

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Cause

Problem due to Microsoft OS UAC settings.

Resolution

Creating the following registry key and restarting Appreadiness Service resolved the issue.

Caution! Refer to the Disclaimer at the end of this article before using the Registry Editor.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Name: EnableLUA 
Type:   REG_DWORD
Value:  0

 

Issue/Introduction

Logon process gets stuck in a black screen in both RDP and ICA Sessions. 

Additional Information