CVAD || Storefront ||load balancer issue with AWS ALB

CVAD || Storefront ||load balancer issue with AWS ALB

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Article ID: CTX694671

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Updated On:

Description

  • When using AWS ALB as load balancer.
  • Getting Error - Cannot connect to the store.

Environment

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Resolution

In AWS ALB there is one option called Sticky Sessions or application stickiness

Enable it in Target Group.

Also make sure Target Group is configured to use http 1 or http1.1

 

 


Problem Cause

As Storefront is a stateful web app and can’t bounce between servers for a session. 

It requires Enabling  Sticky Sessions.

 

Issue/Introduction

When using AWS ALB as load balancer for load balancing Storefront make sure Sticky sessions option is enabled on Target Group settings on Load balancer. Also make sure they are using HTTP 1 or HTTP 1.1 for protocol.

Additional Information

https://docs.aws.amazon.com/elasticloadbalancing/latest/application/application-load-balancers.html