Adobe Acrobat 2024 Smart Card Signing Issue

Adobe Acrobat 2024 Smart Card Signing Issue

book

Article ID: CTX694670

calendar_today

Updated On:

Description

The issue is with Adobe Acrobat 2024 (AcrobatDC24.005.20320) when trying to sign documents with a smartcard within a Citrix session. When we connect to the application server via RDP we can sign documents, but when connected via ICA, we get the following behavior.

Prior to signing, we can confirm that the smartcard cert is visible within Acrobat. It’s after selecting “Sign” that we get a prompt for a smart card that can’t be resolved. Outside of Acrobat, smartcards function normally. In Adobe Reader 2020, we were able to sign documents via smartcard.

Resolution

The issue affects 64-bit versions of Acrobat Reader in Citrix sessions.

During the installation of 64-bit versions of Acrobat Reader, the following registry keys are created.

[HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook] - "ExcludedImageNames"="Acrobat.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\CtxHook] - "ExcludedImageNames"="Acrobat.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\CtxHook64] - "ExcludedImageNames"="Acrobat.exe"

 

To resolve the issue, either install the 32-bit version of Acrobat Reader or delete the above registry keys.


Problem Cause

Adobe Acrobat Reader unable to detect smart card and sign documents in ICA sessions.

The issue affects 64-bit versions of Acrobat Reader.