NetScaler: FQDN based service is Down

NetScaler: FQDN based service is Down

book

Article ID: CTX693404

calendar_today

Updated On:

Description

FQDN based service is not coming UP and showing Server State as DOWN

The Monitor status might be "Domain name not resolved"

 

But from CLI, if you tried to resolve the hostname it might show the response. 

Resolution

Make the DNS Name Servers UP by enabling the PING request/response from SNIP to DNS servers in the network devices (routers/firewalls). 


Problem Cause

The  Effective state of DNS name servers configured on the NetScaler were on the "DOWN" state. Hence the the FQDN based service was not able to get the IP through the DNS names servers.

When a name server is added on the NS, the effective state of that server is determined based on the probe that NS sends between the SNIP/MIP and the name server. The probe is an echo request from the SNIP and echo reply from the name server.
If the probe is successful, the effective state will be seen as UP. 

And for the FQDN based service, the DNS query will be happening if the DNS name servers are UP state. 

Additional Information

Citrix ADC: DNS resolution fails towards Name servers. - https://support.citrix.com/s/article/CTX215665-citrix-adc-dns-resolution-fails-towards-name-servers?language=en_US

DNS Name Server Shows DOWN on NetScaler - https://support.citrix.com/s/article/CTX207954-dns-name-server-shows-down-on-netscaler?language=en_US