User SID is displayed in Workspace UI after sign-in through SAML authentication

User SID is displayed in Workspace UI after sign-in through SAML authentication

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Article ID: CTX693327

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Updated On:

Description

In the use case of SAML using Azure AD and AD identities for Workspace authentication, when end user sign-in Citrix Workspace, Workspace UI just shows a Security Identifier (SID)), instead of the user’s display name.

Resolution

Browse to the SAML application configured in Azure Active Directory > Enterprise Applications in Azure portal. Go to Attributes & Claims section and correct 'displayname' attribute to "displayName".


Problem Cause

By use of SAML-tracer browser extension, it is found that in the SAML assertion, the expected 'displayName' attribute was actually cased as 'displayname'. That results in the value of 'displayname' attribute not being recognized as a username by Citrix Workspace. Alternatively, the value of 'cip_sid' attribute, a Security Identifier (SID), was displayed in the Workspace UI.


Expected Result:

<Attribute Name=\"cip_sid\">
     <AttributeValue>#user_sid#</AttributeValue>
</Attribute>

<Attribute Name=\"displayName\">
     <AttributeValue>#user_display_name#</AttributeValue>
</Attribute>

Actual Result:

<Attribute Name=\"cip_sid\">
    <AttributeValue>#user_sid#</AttributeValue>
</Attribute>

<Attribute Name=\"displayname\">
    <AttributeValue>#user_display_name#</AttributeValue>
 </Attribute>

Issue/Introduction

The article describes a user display issue caused by attribute misconfiguration in SAML application in Azure.

Additional Information

https://docs.citrix.com/en-us/citrix-cloud/citrix-cloud-management/identity-access-management/saml-identity.html#debugging-recommendations