Citrix PVS Console and Server Not Visible to Other Admins After Installed via CLI

Citrix PVS Console and Server Not Visible to Other Admins After Installed via CLI

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Article ID: CTX693319

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Updated On:

Description

After installing the Citrix Provisioning Services (PVS) Console and server version 2402 CU2 on a Windows Server 2019 machine using command line, the application is only visible to the user who performed the installation. Other administrators logging into the same server do not see the Citrix PVS Console or Server in:

  • Programs and Features
  • Start Menu Search

This issue does not occur if the installation is performed using the Graphical User Interface (GUI) and the “Install for All Users” option is selected during setup.

However, when using a silent command line install (e.g., in automated deployments), this behavior becomes apparent in recent versions.

Resolution

If using command line to install, use the following syntax to make the PVS Console available for all users:

<InstallerName>.exe /s /v" ALLUSERS=1 /qn"

This ensures:

  • Shortcuts are created in C:\ProgramData\Microsoft\Windows\Start Menu\Programs
  • The application appears in Programs and Features and Start Menu search for all administrators on the server

Problem Cause

When installing Citrix PVS version 2402 and later, when installed via command line using:

<InstallerName>.exe /s /v"/qn"

The application is installed only for the current user executing the command. This change in behavior differs from earlier versions such as 2203 LTSR, where the same silent install syntax resulted in a system-wide installation.