PVS boot fails for Server 2025 based PVS vdisks running on Azure and Hyperv after windows update

PVS boot fails for Server 2025 based PVS vdisks running on Azure and Hyperv after windows update

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Article ID: CTX693222

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Updated On:

Description

When applying windows updates to a PVS vdisk with Server 2025 which is running on Azure or Hyper-V, after rebooting to finish installing windows updates, PVS boot fails.

 

Issue when applying windows updates to a PVS Streamed server 2025 vdisk:

  1. The vdisk is booted in read/write mode
  2. Windows updates are applied and windows will prompt for a reboot to complete update install.
  3. After rebooting the PVS target device, windows will BSOD with generic failure around CvhdMp.sys.

 

Issue when applying windows updates to a reverse imaged server 2025 vdisk

  1. The vdisk is reverse imaged.
  2. PVS target device software is not removed.
  3. Windows updates are applied and windows reboots and completes update install.
  4. Imaging wizard is run to capture a new vdisk and rebooted to complete vdisk creation process.
  5. Windows will BSOD with generic failure around CvhdMp.sys when PVS booting.

 

Resolution

Azure and Hyper-V based server 2025 vdisks must be reverse imaged to apply each windows monthly patch, and PVS target device software reinstalled after windows update is completed.

Steps:

  1. Reverse image the server 2025 vdisk.
  2. Uninstall PVS target device software.
  3. Apply windows updates
  4. Reboot windows to complete windows update install.
  5. Reinstall PVS target device software.
  6. Capture a new vdisk from this updated windows install.

 


Problem Cause

Server 2025, when applying windows updates, windows update removes and installs a new version of Hyper-V network driver NetVsc.

  • The NetVsc network driver is used by both Azure and Hyper-V based virtual machines.
  • A result of windows update uninstalling the NetVsc driver, is that the critical BootFlags registry, that PVS target device installer placed during installation is no longer present, and PVS boot will fail.
  • Reinstalling PVS target device software after applying windows updates will restore required BootFlags for NetVsc.

Additional Information

https://support.citrix.com/s/article/CTX330966-simplified-steps-for-reverse-imaging-pvs-vdisk-to-citrix-hypervisor-vm?language=en_US