PVS configuration wizard error - Unable to communicate with license server

PVS configuration wizard error - Unable to communicate with license server

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Article ID: CTX693195

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Updated On:

Description

When upgrading the PVS farm to PVS 2402, PVS configuration wizard could not progress further if "Validate license server communication" was checked, displaying an error "Unable to communicate with the license server, or the license server version is not compatible with this version of Citrix Provisioning. Please install or upgrade license server."

 

The following checks were completed:

  • Prior to the PVS servers upgrade, the license server should be upgraded to the latest version, this was checked and confirmed to be running the latest license server version.
  • The license server console was opened on the license server and validated that it was operating as expected and had license files.
  • Testing connectivity from the PVS server to the license server on the ports shown in configuration wizard (27000 and 8083) via telnet and also via PowerShell test-networkconnection showed these ports were open.
  • Documentation was checked for ports used by PVS against Citrix License Server if additional ports were also used, but documentation showed TCP ports 27000 and 8083.
  • Wireshark analysis of a network trace captured on the license server when running PVS configuration wizard on the PVS server showed several connection attempts, all followed by immediate TCP resets.
  • Wireshark analysis also indicated a network security appliance/firewall was in between the PVS server and License server.
  • Using a web browser on the PVS server to open the license URL https://licenserver.domain.name:8083 failed, demonstrating that communication to the license server was also failing with third party software. 

Resolution

  1. The network security appliance firewall was reconfigured to allow TCP connections which were encrypted by Transport Layer Security (TLS) between the Citrix PVS server and the Citrix License Server
  2. Communication between the PVS server and License Server was then validated by using a web browser on the PVS server to open the license server URL https://licenserver.domain.name:8083 and access the licensing console.
  3. PVS configuration wizard was then able to proceed further when "Validate license server communication" was checked in the PVS configuration wizard dialogue.

Problem Cause

When the problem was being reproduced the network security appliance firewall:

  • Allowed network communication using other protocols which were not encrypted, so telnet or other basic TCP connectivity tests were not affected and showed the ports were open. 
  • Prevented network communication over port 8083, when using TCP connections which were encrypted by Transport Layer Security (TLS). This encrypted communication was intercepted and interrupted by the network security appliance firewall.

Additional Information

https://community.citrix.com/tech-zone/build/tech-papers/citrix-communication-ports/