Microsoft Edge taskbar icon may not appear when it is launched through Local App Access

Microsoft Edge taskbar icon may not appear when it is launched through Local App Access

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Article ID: CTX693186

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Description

When Microsoft Edge is launched in an ICA desktop session through Local App Access (LAA), Microsoft Edge icon may not appear in Windows taskbar of the session. In the situation, if end user makes a mouse click on the background Windows desktop in the session, the foreground Microsoft Edge window will disappear. 
Ideally, in the LAA use case, Microsoft Edge taskbar icon should reside in Windows taskbar of ICA desktop session, and Microsoft Edge windows can be minimized and restored through the taskbar icon.

Resolution

Before launching Microsoft Edge in an ICA desktop session through LAA, please ensure there is no existing msedge.exe instance running in the client endpoint.
It is also recommended to disable Microsoft Edge auto-start from Windows task manager "Startup" tab of the client endpoint, so as to avoid msedge.exe running without user's awareness.


Problem Cause

For Microsoft Edge application, the first msedge.exe instance will be the UI process that presents a taskbar icon. If there's an existing msedge.exe instance running in the client endpoint, and then a second msedge.exe instance is launched in ICA desktop session through LAA, then LAA module cannot retrieve the task icon because the first msedge.exe instance (the UI process) is out of management of Citrix LAA.

Issue/Introduction

The article describes a by-design/limitation of Microsoft Edge with Citrix LAA.