CWA smartcard logon error 'Can’t read smart card' on client with SIM card
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Article ID: CTX693018
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Updated On:
Description
There is a client with 2 smart cards . A physical smart card and an integrated eSIM .
When CWA Windows tries to autenticate with smartcard the user gets an error that says "Can't read smart card. Please contact your IT administrator" .
If we remove the SIM card from the client , the authentication with Smartcard works fine.
Resolution
Citirx does support this use case for now.
A workaround is to Disable UICC iso Device in device manager and the problem should be avoided .
Problem Cause
The SmartCardManager will enumerate all connected smartcards. We don't recognise the ESim as we don't support this type of card .
If one of the cards fails to be enumerated then the process stops and smart card logon fails .
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