Citrix Virtual Apps and Desktops - Unable to EDIT Published DualAdmin APP-V application in WebStudio

Citrix Virtual Apps and Desktops - Unable to EDIT Published DualAdmin APP-V application in WebStudio

book

Article ID: CTX693004

calendar_today

Updated On:

Description

Admin cannot edit some of the published applications.

Affected applications: Dual Admin APP-V Applications

Error displayed:

 

More details:

Action Name: APP_ApplicationProperties

Exception:
    StudioErrorId : UnknownError
    Error Source : CitrixAppVService
    Sdk Error Message : Cannot process command because of one or more missing mandatory parameters: AppVPublishingServer.

 

When you select APP-V application in WebStudio (Applications node), App-V publishing server is not displayed in Details tab:

 

 

 

 

 

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

Please note: This article, examples and solution applies to environments where only a single APP-V server pair (Management/Publishing server) is used. Examples below show a very simple scenario.

In environments with multiple APP-V servers configured it is expected to have multiple broker machine configurations and solution is more complex.

We strongly recommend Customers to contact Citrix Support.

 

Verify if the link between Applibrary and Broker is broken.

1 - Open Powershell on the Delivery Controller as administrator.

2 - Check UID of the record stored in AppLibrary:

Get-AppLibAppVServer

Example:

3 - Check Configuration Slot used by APP-V Dual Admin mode:

Get-BrokerConfigurationSlot -Name AppV

Example:

4 - Check Broker Machine Configuration used by APP-V Dual Admin (ConfigurationSlotUid = Uid from the Step 3)

Get-BrokerMachineConfiguration -ConfigurationSlotUid 2

Example:

What we can see above:

Uid from Step 2 = 2

LeafName from Step 4 = 1

This is the issue. The LeafName value is not the same as Applibrary AppVServer Uid.

 

Workaround/Solution:

1 - Publish a new App-V application to Delivery Group. You can delete it after. Publishing will create a new broker machine configuration.

2 - Check Broker Machine Configuration used by APP-V Dual Admin (Remember to used correct ConfigurationSlotUid):

Get-BrokerMachineConfiguration -ConfigurationSlotUid 2

Example:

As you can see we have 2 configurations now. New configuration has LeafName value = 2 which is matching Uid from AppLibrary.

3 - Reassociate existing application with a new Broker Machine Configuration (Uid = 3)

From the output above we know that there is application with Uid=11 associated with old configuration (Uid = 2)

4 - Remove application from Configuration:

Get-BrokerMachineConfiguration -Uid 2 | Remove-BrokerMachineConfiguration -Application 11

5 - Add Application to a new Configuration (Uid = 3)

Get-BrokerMachineConfiguration -Uid 3 | Add-BrokerMachineConfiguration -Application 11

6 - Update Application Metadata

Set-BrokerApplicationMetadata -Name Citrix_DesktopStudio_MachineConfigurationUid -Value 3 -ApplicationId 11

Problem Cause

App-V Server record removed from AppLibrary. Admin removed server using Remove-AppLibAppVServer cmdlet.

The link between Broker (Machine configuration) and AppLibrary (AppVServer) broken.