Shadow Options are Unavailable in the ICA Listener or Management Server Consoles

Shadow Options are Unavailable in the ICA Listener or Management Server Consoles

book

Article ID: CTX692980

calendar_today

Updated On:

Description

  • The shadowing options on the Advanced Connection Settings dialog box of the listener are unavailable or restricted.

  • If the shadow options are unavailable, all options were restricted during installation.

  • If some of the options appear and some do not, the missing options are the ones restricted during installation.

  • The shadowing options for the RDP listener might also be unavailable.

  • The Citrix Management, Access Management, and Discovery Services Consoles might not display the Shadow option.

Resolution

Complete the following steps to resolve the issue:

  1. Reinstall XenApp.

  2. Remove the Windows 2003/2008 Policy. To remove the policy in Windows 2003, complete the following procedure:

    1. Type gpedit.msc to open the Local Group Policy Editor.
    2. Navigate to Local Computer and/or User Policy > Computer and/or User Configuration > Administrative Templates > Windows Components > Terminal Services > Sets rules for remote control of Terminal Services user sessions.
    3. Remove the policy.
  3. Check for the existence of the following registry value:
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Terminal Services\Shadow
    If the value exists, delete it and restart the server, so the option must be available. If the value returns after restart, it indicates that there is a Group Policy attached.

  4. Install an ICA Client (Citrix Receiver) on the Server if not currently present.
    Note: The Citrix install process does not log the selected shadowing options. The CHFarm process does not allow the shadowing selection to be altered.
    Installing an ICA client without the pass-through /SSON option causes the user who is initiating the shadow session to enter the user credentials before the shadow session is initiated.


Problem Cause

  • An ICA Client is not installed on the Server.

  • Recreating the ICA Listener does not resolve this issue. The registry cannot be manipulated to alter the original selection. These selections can be altered only if reinstalled.

  • "Shadowing restrictions are permanent. If you disable shadowing, or enable shadowing but disable certain shadowing features, the restrictions cannot be changed at a later time."

  • A Windows 2003/2008 Policy is enabled. The following are the details of the policy: 

    • Windows 2003: In the Group Policy Editor, the location of the policy is Local Computer User Policy > Computer and/or User Configuration > Administrative Templates > Windows Components > Terminal Services > Sets rules for remote control of Terminal Services user sessions.
    • Windows 2008: In the Group Policy Editor, the location of the policy is Local Computer Policy > Computer and/or User Configuration Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host Connections Sets rules for remote control of Remote Desktop services user sessions, as shown in the following screen shot.

      User-added image

Additional Information

CTX040083 – Troubleshooting and Explaining Citrix ICA Shadowing
CTX122676 – How to Install the Web Plug-in and the Pass-Through Authentication Component for Use with ICA Files or Web Interface