NetScaler Gateway - App launch failure Error: "Session reconnection timeout"

NetScaler Gateway - App launch failure Error: "Session reconnection timeout"

book

Article ID: CTX692918

calendar_today

Updated On:

Description

 

Users attempts to launch an application externally via NetScaler Gateway and observed the below error

 

Application launch fails consistently and the behavior is same with both web browser and the Citrix Workspace Application

 

 

 

Resolution

 

Workarounds

 

1) Failover to the secondary node

2) Rebooting the primary will reset the dynamic server connections

 

Permanent Fix

 

Below firmware version includes the fix for this issue

13.1 - 57.26 and above

14.1-38.53 and above

 

 


Problem Cause

 

The connections to the Virtual Delivery Agent (VDA) are considered "dynamic" because the destination port numbers are not predefined or statically configured. Instead, these port numbers are assigned dynamically during the VDA connection establishment process.

 

This behavior is seen when the number of dynamic server connections surpasses the threshold of 64,000. This limit restricts the number of dynamically created server entries, and once exceeded, it prevents new application sessions from being initiated.

 

Each Packet Engine (PE) has a maximum capacity of 64,000 such dynamic connections, and in this case, that limit has been reached.

 

To validate if this is the cause, execute the following command:

 

# nsconmsg -K newnslog -d stats -g curdynamic_serverinfo 

 

Primary node:

 

Secondary node : 

The value is below the limit(64000)