Windows 365 Cloud PC VDAs registration getting stuck at initializing state

Windows 365 Cloud PC VDAs registration getting stuck at initializing state

book

Article ID: CTX692850

calendar_today

Updated On:

Description

Windows 365 Cloud PC VDAs getting stuck at initializing state, users cannot access the desktop

On the VDA,  Citrix Gateway service (NGS) logs located in "C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Citrix\Ngs" directory will show the below errors.

 

TimeStamp=2025-03-18T07:18:59.591082Z ProcessID=23548 : {"Severity":"ERROR","Method":"proxy.(*Conn).Read","Message":"[E306] Connection read failed","TransactionID":"52b4333f-10a9-479c-96fc-d95c36ed570e","CustomerId":"<Customer ID>","VdaUuid":"4bd67c98-e98c-45c5-9f0a-d0ee272ebab2","Local Address":"<VDA IP>:63922","Remote Address":"3.105.3.204:443","error":"read tcp <VDA IP>:63922->3.105.3.204:443: i/o timeout"}

TimeStamp=2025-03-18T07:18:59.591082Z ProcessID=23548 : {"Severity":"ERROR","Method":"ngs-connector.(*Connector).handleVdaRegister","Message":"POST HTTP error during VDA Register request","TransactionID":"52b4333f-10a9-479c-96fc-d95c36ed570e","CustomerId":"<Customer ID>","VdaUuid":"4bd67c98-e98c-45c5-9f0a-d0ee272ebab2","error":"HTTP read failed with err 'read tcp <VDA IP>:63922->3.105.3.204:443: i/o timeout'"}

 



 

Resolution

Update the firewall rules for VDAs to allow the Citrix Gateway service traffic as per Citrix Gateway service connectivity requirement.



Problem Cause

Proxy server blocking the communication to Citrix Gateway Service 

Additional Information

CTX270584: Citrix Gateway Service – Points of Presence (PoPs)