Citrix Storefront - Error "404 - File or directory not found" when accessing Storefront URL

Citrix Storefront - Error "404 - File or directory not found" when accessing Storefront URL

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Article ID: CTX692844

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Updated On:

Description

Browsing to Storefront web URL results in below error "404 - File or directory not found. The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable."

 

Environment

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Resolution

Navigate to IIS->Click on the site for storefront -> Click on Request Filtering -> Navigate to Edit Feature Setting under Actions,

Make sure to check the option for "Allow unlisted file name extensions". Do not make any other changes. 

 

Restart IIS.

Test behavior by browsing to the URL and everything should work as expected.


Problem Cause

"Allow unlisted file name extensions"  option under Request Filtering on IIS was unchecked. This option is checked by default and it is a required setting.

Additional Information

For additional information about File Name Extensions refer to the following documentation:

File Name Extensions <fileExtensions> | Microsoft Learn