CVAD: Logon Duration is not reported if "Do not process the legacy run list" group policy is enabled

CVAD: Logon Duration is not reported if "Do not process the legacy run list" group policy is enabled

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Article ID: CTX692758

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Updated On:

Description

Logon Duration is not logged in Citrix Director if  "Do not process the legacy run list" group policy is enabled

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Ensure that "Do not process the legacy run list" is not enabled.

 

Using Local Group Policy Editor: Navigate to "Computer Configuration" > "Windows Settings" > "Security Settings" > "Logon scripts" and find the "Do not process the legacy run list" policy

 

Reg Location: https://admx.help/?Category=Windows_10_2016&Policy=Microsoft.Policies.WindowsLogon::DisableExplorerRunLegacy_1

Registry HiveHKEY_CURRENT_USER
Registry PathSoftware\Microsoft\Windows\CurrentVersion\Policies\Explorer
Value NameDisableCurrentUserRun
Value TypeREG_DWORD
Enabled Value1
Disabled Value0

 

Reference: https://support.citrix.com/s/article/CTX213259-logon-performance-data-not-available-on-director?language=en_US


Problem Cause

Do not process the legacy run list group policy setting, when enabled, prevents the system from executing applications listed in the old "Run" registry key during user logon and hence, the VDA does not execute the legacy run list of applications and scripts that are typically processed during user logon. 

The "Do not process the legacy run list" policy, when enabled, can lead to issues with logon duration data not being recorded in Citrix Director. This is primarily because this policy affects how the Virtual Delivery Agent (VDA) processes logon scripts and applications during the user logon process.

Reference link: https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/2402-ltsr/director/troubleshoot-deployments/user-issues/user-logon.html#prerequisites