uberAgent on MacOS displays splash screen at login, fails to recognize license file
book
Article ID: CTX692754
calendar_today
Updated On:
Description
uberAgent on MacOS displays a splash screen at login advising users: "Evaluation Version. Not for Production Use."
uberAgent.log will show failure to read the licensing file.
- LicenseCheck,Starting license verification
- LicenseCheck,Copying license files from </Library/Application Support/uberAgent> to cache </Library/Application Support/uberAgent/License Cache>
- LicenseCheck,Reading license file: </Library/Application Support/uberAgent/License Cache/uberAgent.lic>
- LicenseCheck,Invalid entry: value has no data in line
- LicenseCheck,Failed to read or verify license file: Input/output error
- LicenseCheck,Finished license verification for component <User experience monitoring>. Result: unlicensed
- LicenseCheck,Finished license verification for component <Endpoint security analytics>. Result: unlicensed
Resolution
Use a text editing tool to convert the encoding of the license file from UTF-8 to UTF-16 LE BOM.
Problem Cause
The Citrix licensing portal is currently generating license files encoded in UTF-8 format. This is functional for all Windows agents, but is unreadable by MacOS agents.
Issue/Introduction
Citrix licensing portal generates license files in UTF-8 encoding, which is not readable by MacOS agents, and must be converted to UTF-16 LE BOM.
Was this article helpful?
thumb_up
Yes
thumb_down
No