Netscaler VPX : NTP_Sync Failing even after ntp process restart

Netscaler VPX : NTP_Sync Failing even after ntp process restart

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Article ID: CTX692705

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Updated On:

Description

Netscaler VPX is configured with NTP sync to pool.ntp.org or any NTP server, but the NTP sync does not work even after disabling and enabling NTP sync and also restarting the NTP process.

Resolution

Hypervisor can sync time to the Netscaler VPX hosted on it, and if time sync is enabled on Hypervisor, then NTP sync on Netscaler VPX fails.

Disabling time sync on the hypervisor and rebooting the VPX node resolves the issue. 


Problem Cause

NTP Sync is failing as time synchronization is enabled on the hypervisor for the Netscaler VM.

When checked under the NTP log, we can see below.

19 Feb 16:00:05 ntpd[5081]: 0.0.0.0 c01d 0d kern kernel time sync enabled

19 Feb 16:00:05 ntpd[5081]: kernel reports TIME_ERROR: 0x2041: Clock Unsynchronized

Additional Information

https://support.citrix.com/s/article/CTX121356-how-to-manually-set-the-time-on-a-netscaler-appliance?language=en_US

https://support.citrix.com/s/article/CTX201156-time-display-on-netscaler-does-not-sync-using-ntp?language=en_US