Session Recording 2402 - Sessions not getting recorded even though Session Recording is enabled

Session Recording 2402 - Sessions not getting recorded even though Session Recording is enabled

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Article ID: CTX692698

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Updated On:

Description

When the user logs on, users were not seeing the Session Recording notification and also the sessions did not get recorded. We can see some 0KB files on the server side. Session Recording policy was set to record sessions for all users with notification. Session Recording Agent was configured to use HTTPS to communicate with the Session Recording server. 

Environment

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Resolution

Following steps were required to resolve the problem:

  1. HTTPS was added to the IIS Default Website Bindings and appropriate Certificate was installed on the Session Recording Server:

       2. Modified the "Access this computer from network"  policy applying to the Session Recording Server to make sure all the default values are present. The defaults are: Administrators , Backup Operators, EveryOne, Users

       3. TCP Port 1801 was opened between the Session Recording Agent and the Session Recording Server (This is required when using TCP as the Protocol for "Session Recording Storage Manager Message queue" settings on the Session Recording Agent Properties. When using HTTPS, port 443 needs to be opened.

These changes resolved the problem.


Problem Cause

Incorrect configuration.

Additional Information

Setting up SSL on IIS 7:

https://learn.microsoft.com/en-us/iis/manage/configuring-security/how-to-set-up-ssl-on-iis#iis-manager

Communication Protocol Configuration in Session Recording Server:

https://docs.citrix.com/en-us/session-recording/2402-ltsr/configure/settings-on-session-recording-agent/change-communication-protocol