DaaS - Issue with cloud connectors after upgrade failure

DaaS - Issue with cloud connectors after upgrade failure

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Article ID: CTX692358

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Description

  • The cloud connector connectivity test fails.
  • Run sfc /scannow in Administrator Command Prompt to check for corrupt files.

 

Resolution

  • Cloud Connector automatic upgrade executed by Citrix DaaS failed and the CCs entered a hung state.
  • After reinstalling the Cloud connector, the connectivity test is stuck.
  • Ran sfc /scannnow in Administrator Command Prompt and found corrupt files.
  • Ran dism /online /cleanup-image /restorehealth 
  • Checked the CBS logs at C:\Windows\Logs\CBS to get more information about the kind of corruption.
  • Any installation or upgrade would probably fail when there are Manifest and Payload corruptions at the OS level.
  • Need to update the Windows patch to fix the corruptions or manually fix the corruptions.

 


Problem Cause

-The cloud connector upgrade failed due to OS corruptions. 

-The Windows patching is not up-to-date.

Additional Information