Citrix Workspace App for MAC - Intermittent sign in failure, browser access works

Citrix Workspace App for MAC - Intermittent sign in failure, browser access works

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Article ID: CTX692083

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Updated On:

Description

Administrators may notice that the Mac end points intermittently fail sign into workspace app. Visiting the store via browser would work consistently. 

Resolution

Make sure to use FQDN when configuring the Store address. For example, https://FQDNofYourDomain/Citrix/Store/discovery

Also use the same fqdn format when configuring beacons on the storefront server.


Problem Cause

CWA for MAC uses internally an Apple Framework which works consistently with FQDN rather than netbios name.

Additional Information

CWA for MAC verbose logs will show Network_Location_None when attempting to reach the beacons:

 [ServiceRecordMain.mm:157]  [+] -[CtxBeaconSvr checkLocationForStore:completionHandler:] (https://NonFQDN/Citrix/StoreName/discovery)
[T0Unknown] [ServiceRecordMain.mm:157]  -[LocationManager locationRelativeToStoreURL:] Checking Location - https://NonFQDN/Citrix/StoreName/discovery
[T0Unknown] [ServiceRecordMain.mm:157]  -[LocationManager locationRelativeToStoreURL:] Checking serviceRecordLocation - https://NonFQDN/Citrix/StoreName/discovery

[T0Unknown] [ServiceRecordMain.mm:157]  -[ServiceRecordLocation reachability]    Internal Beacon Beacon Detector for "https://NonFQDN/Citrix/StoreName/discovery"  reach = "kNotReachable" kNotReachable
[T0Unknown] [ServiceRecordMain.mm:157]  -[LocationManager locationRelativeToStoreURL:] Location = "kNETWORK_LOCATION_NONE"   (Detector = "Service Record)"
[T0Unknown] [ServiceRecordMain.mm:157]  [-] -[CtxBeaconSvr checkLocationForStore:completionHandler:] (NETWORK_LOCATION_NONE)