VDA Installer Only Displays Splash Screen then Closes

VDA Installer Only Displays Splash Screen then Closes

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Article ID: CTX691899

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Updated On:

Description

When installing the workstation VDA, the Installer Splash Screen appears for a second then disappears.  

Nothing is logged in the installer logs

There are no crashes reported in the eventlogs

DebugView shows the installer exits with status Code: 1

Using the Citrix VDA Cleanup Utility Tool does not resolve the issue (https://support.citrix.com/s/article/CTX209255-citrix-vda-cleanup-utility-tool?language=en_US)

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Enable 64-bit support for .Net framework

Browse to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework

Change the Enable64Bit reg key to 1

Restart the VDA


Problem Cause

The Citrix installer uses the 64-bit version of .NET Framework, but there was a system wide setting: Enable64Bit, located in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework was set to a value of 0 which forces all dotNet applications including installers to use the 32-bit framework version.

Citrix Technical Support believes this was set by a 3rd party installer.

 

Issue/Introduction

How to resolve an issue where installing the workstation VDA, the Installer Splash Screen appears for a second then disappears. 

Additional Information

Citrix Desktop Service Will Not Start or Restart After Installing .NET Based Applications on 64-Bit Windows Platforms - http://support.citrix.com/article/CTX140116

Citrix VDA Cleanup Utility Tool - https://support.citrix.com/s/article/CTX209255-citrix-vda-cleanup-utility-tool?language=en_US