All Hosts missing from PVS Desktop Wizard

All Hosts missing from PVS Desktop Wizard

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Article ID: CTX691871

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Updated On:

Description

When trying to create a catalog using the PVS Desktop Wizard, the host list may be empty even though the Delivery Controller you are connecting had Hosts configured.   You may also not see the option to add hosts in the PVS console.

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Delete HKLM\SYSTEM\CurrentControlSet\Services\WindowsAzureGuestAgent on the PVS server and then rerun the Configuration Wizard.


Problem Cause

PVS checks whether or not the server in in Azure, at the time of this writing, it does that by checking for the existence of HKLM\SYSTEM\CurrentControlSet\Services\WindowsAzureGuestAgent.  If it finds that key, it will believe the PVS server is in Azure.  WindowsAzureGuestAgent could have gotten installed on that server.  Uninstaling that agent does not delete that key.  

You can confirm this is the case by checking the Configuration Wizard, C:\ProgramData\Citrix\Provisioning Services\ConfigWizard.log.  If it says its in Azure and you are on an on-prem server, this would likely be the cause.