App Layering - Changes to Scheduled Tasks do not show up on the layered image

App Layering - Changes to Scheduled Tasks do not show up on the layered image

book

Article ID: CTX691811

calendar_today

Updated On:

Description

Making changes to an existing scheduled task will not be reflected on the published image. Adding a version to the layer shows the old values and not the changes.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

This behavior is expected, but it can be disabled for app layers where modifying a Scheduled Task is needed. It is not recommended to add this key to your OS layer.

 

Please run the following from an administrator command prompt:

reg  add  HKEY_LOCAL_MACHINE\SOFTWARE\Unidesk\ULayer /v  DisableScheduledTasksScrubOnFinalize /t  REG_DWORD /d 1


Problem Cause

 Restricting changes to existing schedule tasks corrects an issue seen with Windows Defender updates.