Migration of Android Devices registered via GCM to FCM

Migration of Android Devices registered via GCM to FCM

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Article ID: CTX691804

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Updated On:

Description

There is no automatic update from Azure Notification Hub or Google Push Notification Service to migrate Android clients from the FCM legacy protocol to the latest FCMv1 protocol. As a result, affected users will need to manually re-register their devices with NetScaler Gateway. Please refer to the “Re-register your Android device” Section for detailed instructions on how to complete the re-registration.

Workaround: Users can fallback to the TOTP authentication method until their devices are re-registered.

Resolution

In this article we are going to share how to Migrate Android Devices registered via GCM registration template to FCM registration template

Android devices registered for the Push Notification Service before July 20, 2024, will no longer receive push notifications from September 20 2024.

This change only affects Android devices registered with the NetScaler Push Solution and does not impact iPhone devices.

Android devices registered with the NetScaler solution on or after July 20, 2024, will not be affected by this change.

Re-register your Android device

Users are required to re-register their devices with NetScaler Gateway to enable push notification functionality. Please note that different organizations may have varying methods for accessing the registration FQDN. Therefore, affected users are advised to contact their respective administrators for assistance in reaching the correct registration FQDN. Below is a sample process for re-registration.

 

<Step-1> Delete/Unregister Old Android Device

Delete all the already registered android devices (for which you are not receiving push notification) with NetScaler Gateway. 

To delete individual devices please follow the sequence of steps mentioned below. And repeat the same for all the older registered devices for which you are not receiving push notification.

  1. In your web browser, browse to your NetScaler Gateway FQDN, and suffix /manageotp to the FQDN. Please note this is an example endpoint and for respective users need to contact their respective organisation for exact URL.
    This loads the authentication page. Example: https://gateway.company.com/manageotp

  2. Log in using your appropriate authentication mechanisms, as specified by the organisation. Once authentication is successful the user should see the Push Registration Portal page like below. In the dropdown select the appropriate android device. Ex: Here ‘Android device’ selected.
    1.jpg  

  3. Click Delete Device. You need to select your appropriate android device for which you are not receiving push notification. After selecting, you should see the confirmation delete dialogue box.
    2.jpg  
  4. Please confirm Delete by clicking on Yes

  5. A QR code is displayed on the NetScaler Gateway browser page.
    3.jpg  
  6. Scan this QR code using the Citrix SSO app from the device which was previously registered.

    Citrix SSO validates the QR code and then goes ahead with the de-registration of the device with the gateway (previously registered for push notifications). If there are no errors in the device deregistration process, then older android device will be successfully removed from the NetScaler Gateway.

 

<Step-2> New Registration of Android Device 

Now register the android device with Netscaler Gateway.

To register the android device please follow the sequence of steps mentioned below. 

  1. If you don’t have any registered device, then you should see below screen 
    4.jpg  

    Or If you already have devices registered, then you should see below screen
    5.jpg  

  2. Click Add Device (or + depending on which screen you are seeing) . In the example we are adding a new device with the name “NewAndroidDevice”.
  3. You should see the screen below. Note example is showing when there is no active registered device. 
    6.jpg  
  4. Enter a name for your device, then click Go. Ex: Here we added NewAndroidDevice
    7.jpg  
  5. Scan this QR code using the Citrix SSO app from the device to be registered.
    Citrix SSO validates the QR code and then registers with the gateway for push notifications. If there are no errors in the registration process, the token is successfully added to the password tokens page.

<Step -3> Test the Device After Adding to NetScaler Gateway

After registering the device using the above steps, you can verify whether the device successfully registered with NetScaler Gateway using Test one-time password authentication.

  1. To test the OTP, click your device from the list and then click Test
    8.jpg  

  2. Enter the OTP that you have received on your device and click Go.
    The OTP verification successful message appears.

    9.jpg  

Problem Cause

Previously, NetScaler Gateway Push Notification feature used the Google FCM legacy API for registering Android devices until July 20, 2024. However, starting in July 2024, the solution transitioned to the latest FCMv1 registration template following Google’s end of service announcement.

As a result, users attempting to log in using push notifications on devices registered with the old Google FCM legacy protocol will no longer receive notifications on their Android devices due to Google's end-of-service announcement.

Issue/Introduction

Migration Steps for Android Devices registered via GCM (Google Cloud Management) to FCM (Firebase Cloud Messaging)

Additional Information

Android devices registered for the Push Notification Service before July 20, 2024, will no longer receive push notifications from September 20 2024.

This change only affects Android devices registered with the NetScaler Push Solution and does not impact iPhone devices.

Android devices registered with the NetScaler solution on or after July 20, 2024, will not be affected by this change